F2 AUTO GEARS + RIM COLORS

Posted by Pont 
F2 AUTO GEARS + RIM COLORS
Date: August 20, 2019 06:18PM
Posted by: Pont
ii have installed auto gears in the gp4 settings but when i play i don't have auto gears...i only get gear one...? It remains at gear one? I also changed the rims of my car in black in still of grey (with gp4 tweaker) but the rims are still grey in my game?
Re: F2 AUTO GEARS + RIM COLORS
Date: August 20, 2019 11:24PM
Posted by: Noog
Gears: Had the same problem the other day with a different mod, but can't remember how I fixed it - only that it wasn't the easy fix I expected it to be.

Mine stayed in first also but was stuck at the pit limit maximum speed. Is yours like that or does it rev to maximum?

Rims: Does your gp4tweak.ini file have this line?:

RimsColors = 1 ; set to 1 to enable rims color tweak
Re: F2 AUTO GEARS + RIM COLORS
Date: August 21, 2019 09:26PM
Posted by: Pont
Mine stays in first gear, also whe i leave the pits no matter what i do.
where can i find the gp4tweak.ini file?
Re: F2 AUTO GEARS + RIM COLORS
Date: August 21, 2019 10:58PM
Posted by: Noog
It's usually in the GP4 game folder - so if you don't have it, you might not have to worry about it, since it can't be causing your problem. It's not an essential file to run the game.

As far as I know there are TWO other (completely unrelated) ways to set rims:

1. Load up TeamEditor3.5 and look under the TEAMS tab.

What do you see in there? Do the rims colours match what you are seeing or not? If they do, change them. If not, changing them probably won't work.

If NO rim colours are set there, or they are neither grey or black, don't worry about it - it's not your problem.

2. Specify tyre and wheel parameters in the performance file (usually found in your GP4/gpxpdata folder)

In the performance file you are using (assuming you are loading the game using GPxPatch.exe) the name of the PF you are using is shown under the GPxSet tab.

See if the PF has a section looking something like this:

[TyreTextureNames]
Name #00=goodyear
Name #01=bbs-black-white
Name #02=bbs-gold-red

and this:

[WheelTextures]
Team #00=10
Team #01=9
Team #02=3

You might not have either section. That's OK. DO NOT add it in as it DEFINITELY won't fix your problem. If you do have those sections, let me know.

If NONE of the above gets you any closer, I'd try re-installing the mod.

Back to the gears:

When you leave the pits I understand that you stay in 1st gear. However, as I asked above, do you ALSO stay at the pit limit speed?

Maximum revs in 1st gear will usually be faster than the pit limit speed so it's an important thing.

a) If you stay the same SPEED both in the pit and track, your pit limiter is broken.
b) If the speed goes UP a bit when you hit the track but you are still stuck in 1st gear, your auto-gears are broken.

If it's a) the answer probably lies in the gp4tweak.ini file again or maybe something in CSM - best idea would be to re-install the mod.
If it's b) make sure you have selected auto-gears properly in the GAME menu under DRIVING AIDS - GAME OPTIONS. When you've done that, exit the game and save the settings when prompted. Then, if you load up the game again and back into DRIVING AIDS - GAME OPTIONS, is the auto-gears option still set?

Hope that helps. It's should be much easier and quicker to fix than it is to write about!
Re: F2 AUTO GEARS + RIM COLORS
Date: August 23, 2019 09:27PM
Posted by: Pont
Noog Schreef:
-------------------------------------------------------
> It's usually in the GP4 game folder - so if you
> don't have it, you might not have to worry about
> it, since it can't be causing your problem. It's
> not an essential file to run the game.
>
> As far as I know there are TWO other (completely
> unrelated) ways to set rims:
>
> 1. Load up TeamEditor3.5 and look under the TEAMS
> tab.
>
> What do you see in there? Do the rims colours
> match what you are seeing or not? If they do,
> change them. If not, changing them probably won't
> work.
>
> If NO rim colours are set there, or they are
> neither grey or black, don't worry about it - it's
> not your problem.
>
> 2. Specify tyre and wheel parameters in the
> performance file (usually found in your
> GP4/gpxpdata folder)
>
> In the performance file you are using (assuming
> you are loading the game using GPxPatch.exe) the
> name of the PF you are using is shown under the
> GPxSet tab.
>
> See if the PF has a section looking something like
> this:
>
>
> Name #00=goodyear
> Name #01=bbs-black-white
> Name #02=bbs-gold-red
>
> and this:
>
>
> Team #00=10
> Team #01=9
> Team #02=3
>
> You might not have either section. That's OK. DO
> NOT add it in as it DEFINITELY won't fix your
> problem. If you do have those sections, let me
> know.
>
> If NONE of the above gets you any closer, I'd try
> re-installing the mod.
>
> Back to the gears:
>
> When you leave the pits I understand that you stay
> in 1st gear. However, as I asked above, do you
> ALSO stay at the pit limit speed?
>
> Maximum revs in 1st gear will usually be faster
> than the pit limit speed so it's an important
> thing.
>
> a) If you stay the same SPEED both in the pit and
> track, your pit limiter is broken.
> b) If the speed goes UP a bit when you hit the
> track but you are still stuck in 1st gear, your
> auto-gears are broken.
>
> If it's a) the answer probably lies in the
> gp4tweak.ini file again or maybe something in CSM
> - best idea would be to re-install the mod.
> If it's b) make sure you have selected auto-gears
> properly in the GAME menu under DRIVING AIDS -
> GAME OPTIONS. When you've done that, exit the game
> and save the settings when prompted. Then, if you
> load up the game again and back into DRIVING AIDS
> - GAME OPTIONS, is the auto-gears option still
> set?
>
> Hope that helps. It's should be much easier and
> quicker to fix than it is to write about!

I changed the rim colours in Teameditor but when i go back to my game rims colours are still the same ??

When you leave the pits I understand that you stay in 1st gear. However, as I asked above, do you ALSO stay at the pit limit speed? The answer is YES....i also stay at teh pit limit speed (80),
I'm not using any mod. I have selected auto gears in the Game menu...but whatever i try i always stay at the pit limt speed?:-(
Re: F2 AUTO GEARS + RIM COLORS
Date: August 23, 2019 10:18PM
Posted by: Noog
Gears: that's exactly the problem I had.

I just can't remember how I fixed it - only that I got to the point where I was about to give up - and right then whatever I did last worked.

In your case however, if you don't have a mod installed, why not download TomMk's clean & up to date installation of GP4 and use that?

That'll definitely solve both problems you have.
Re: F2 AUTO GEARS + RIM COLORS
Date: August 24, 2019 12:09PM
Posted by: Pont
I changed the rim colours by changing the petorming file so that's fixed but i still stay in the first gear whatever i try in the game menu. I think the problem started when i used the driving aid editor. I have never had this problem before. Maybe i have to use a new gp4.exe file....
Re: F2 AUTO GEARS + RIM COLORS
Date: August 24, 2019 09:58PM
Posted by: Noog
A new GP4.exe might be worth a try. Nothing to lose if you make a backup, but first, I'd try deleting or renaming the f1gstate.sav. file and the backup: f1system.bak.

Now when you run the game again it should default to rookie difficulty, with auto-gears set to on. Give it a try. I think it might work - although I don't think it's what I did!
Re: F2 AUTO GEARS + RIM COLORS
Date: August 25, 2019 11:00AM
Posted by: Pont
Hi

I have deleted the files and restarted the game but no change at all. The car stays in first gear also when i leave the pits (80km).
Re: F2 AUTO GEARS + RIM COLORS
Date: August 25, 2019 04:21PM
Posted by: Noog
I made a mistake earlier: f1system.bak should have read f1gstate.bak.

Could you please try that again?

ie, delete f1gstate.sav and the backup f1gstate.bak

Now, if it still doesn't work, I think I might be out of ideas.

But that said, since no-one else seems to want to make a suggestion I'll ask how you installed the game/mod you are playing? Did you use CSM or did you download the whole thing? And what year is the season you are playing?

I ask this because you said you fixed the rims by editing the performance file - but in the basic installation of GP4 this shouldn't be possible because you wouldn't have the correct files in the default cars.wad.
Re: F2 AUTO GEARS + RIM COLORS
Date: August 26, 2019 10:51PM
Posted by: Pont
i solved the problem with the pit limit speed by changing some settings in gp4 tweaker..now i have another problem....normally speaking i can go back to the the pits with key command shift and Q but this command is not working anymore? How can i change this?
Re: F2 AUTO GEARS + RIM COLORS
Date: August 26, 2019 11:36PM
Posted by: Noog
Pont Wrote:
-------------------------------------------------------
> i solved the problem with the pit limit speed by
> changing some settings in gp4 tweaker.

Yes, that's it! That's what I did.

Strange thing, for me, what that I didn't even have gp4tweaker in the folder when the fault first occurred. That's why it was my last ditch effort.

As for keyboard shortcuts, there are some in GPxPatch, under the GPxPatch tab > Edit Key Binds - or edit the keys.ini file directly in the gpxdata folder.

Game_QuitRun=Q

Check that. It will probably be fine, so the other place you might need to check is back in GP4Tweaker. Item 13. The Instant Pit Return Disabler. Mine seems to be ENABLED, but Q works, which seems odd. Not sure I've ever clicked it to see what it does - but maybe it's misbehaving like the pit limiter was earlier.
Re: F2 AUTO GEARS + RIM COLORS
Date: August 27, 2019 08:15PM
Posted by: Pont
Noog Schreef:
-------------------------------------------------------
> Pont Wrote:
> --------------------------------------------------
> -----
> > i solved the problem with the pit limit speed
> by
> > changing some settings in gp4 tweaker.
>
> Yes, that's it! That's what I did.
>
> Strange thing, for me, what that I didn't even
> have gp4tweaker in the folder when the fault first
> occurred. That's why it was my last ditch effort.
>
> As for keyboard shortcuts, there are some in
> GPxPatch, under the GPxPatch tab > Edit Key Binds
> - or edit the keys.ini file directly in the
> gpxdata folder.
>
> Game_QuitRun=Q
>
> Check that. It will probably be fine, so the other
> place you might need to check is back in
> GP4Tweaker. Item 13. The Instant Pit Return
> Disabler. Mine seems to be ENABLED, but Q works,
> which seems odd. Not sure I've ever clicked it to
> see what it does - but maybe it's misbehaving like
> the pit limiter was earlier.


The instant pit return was disabled !! I changed this and now when i press shift and q its working again!!
Sorry, only registered users may post in this forum.

Click here to login

Maintainer: mortal, stephan | Design: stephan, Lo2k | Moderatoren: mortal, Vader, stephan | Downloads: Lo2k | Supported by: Atlassian Experts Berlin | Forum Rules | Policy