Win 7 Ultimate. No sound hardware accelleration. [Fixed]

Posted by Camacho 
Win 7 Ultimate. No sound hardware accelleration. [Fixed]
Date: December 18, 2009 05:21PM
Posted by: Camacho
Hi all!!
Recently I have installed my new Win7 Ultimate but GP4 performance is lower than in XP. I can run it normally, but the frames in several moment during a race go down and the PO higher, more than 110%. In XP it did not happen. What could be the reason?
The drives are all updated. Other thing is that I can't activate 2D hardware acceleration in sounds options. I can mark the option, but when I return to the menu it is not marked. Why happen this?

I'm very worry about that because for me, GP4 is sacred and the performance is lower than before.

Please some help friends!

Thanks in advance and a very happy racing from spain!






Edited 2 time(s). Last edit at 12/20/2009 10:50PM by mortal.
Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 18, 2009 06:44PM
Posted by: harjinator
have you tried reinstalling soundcard drivers? I had awful difficulty with sound drivers on Windows 7, and even now i'm still using Vista ones

_______________________________________________________

Team Japan Owner - GPGNC
Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 18, 2009 07:21PM
Posted by: Lo2k
I've the same behaviour here : no hardware activation (nor 2D or 3D) and if I check 2D, it goes uncheck once I closed and reopen the section.
I do believe GP4 has some difficulties to detect modern drivers and thus disables features that are common on every sound card today.

Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 18, 2009 07:40PM
Posted by: aagancia
I don't think its GP4 having a hard time with modern sound drivers. I think its Win7 and Vista dropping support for DirectSound3d which GP4 and most older games utilizes.

I have windows7 and could not put checks on 2d or 3d sound. But, I'm using a creative sound card that has an application called Alchemy to solve this problem. All works like it was in XP with the Alchemy software. But, I did not experience performance issues even without Alchemy.

If your GP4 is slow in Win7, try disabling the sound card and run the game to see if it runs better without the sound card. If it does run better, check if your sound card manufacturer has a solution for directsound3d in Win7. If they don't, I suggest getting a Creative sound card that can run with their Alchemy software.
Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 19, 2009 08:17AM
Posted by: Excalibur
Same trouble here with Windows 7 Ultimate. Did you try to run GP4 under XP mode (Virtual PC) ? I didn't try it but maybe it could fix this problem...

____________________________________________________________________________________________________________________________________________

Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 20, 2009 03:33PM
Posted by: Willb
"Same trouble here with Windows 7 Ultimate. Did you try to run GP4 under XP mode (Virtual PC) ? I didn't try it but maybe it could fix this problem..."

If you try and run it in a virtual machine then no wonder you are having problems! Standard virtual machines emulate generic graphics and sound devices, as well as the fact that you already have a massive overhead from the host OS!

If you have a CPU which can do Hardware Virtualisation however, and have XP mode in windows 7 enabled then maybe this may work, but again im still not sure even the native XP Mode will not suffer a performance impact.

__________________________



Help keep our forums tidy.

Use the search function...
Re: Win 7 Ultimate. No sound hardware accelaration.
Date: December 20, 2009 06:26PM
Posted by: Lo2k
As GP4 only works with XP compatibility mode (sp3 here) for me with Win7 (64bits), it's not the solution anyway in my case.

aagancia schrieb:
-------------------------------------------------------
> I don't think its GP4 having a hard time with
> modern sound drivers. I think its Win7 and Vista
> dropping support for DirectSound3d which GP4 and
> most older games utilizes.
>
> I have windows7 and could not put checks on 2d or
> 3d sound. But, I'm using a creative sound card
> that has an application called Alchemy to solve
> this problem. All works like it was in XP with the
> Alchemy software. But, I did not experience
> performance issues even without Alchemy.
>
> If your GP4 is slow in Win7, try disabling the
> sound card and run the game to see if it runs
> better without the sound card. If it does run
> better, check if your sound card manufacturer has
> a solution for directsound3d in Win7. If they
> don't, I suggest getting a Creative sound card
> that can run with their Alchemy software.

thank you very much. The Alchemy tools works perfect under windows 7. the performance is perfect again like under windows xp. thank you!
Glad to hear it worked for you. What's your sound card by the way?
Creativ Soundblaster Audigy 2 ZS
Hi all friends.
Well, my sound card is creative sound blaster audigy 2 and... yes!! The Alchemy software solves the problem. (Y) Fantastic. Now I can check 2D acceleration, 3D acceleration, EAX effects... and obviously the game performance for me is better, like in Windows XP more or less.hot

Aagancia has the reason about that. Thanks and 1000 times thanks. GP4 is alive again for me!! I could not imagine my videogame-life without GP4.

Thanks again and a very happy racing from Spain!;-)


Re: Win 7 Ultimate. No sound hardware accelleration. [Fixed]
Date: December 21, 2009 09:02PM
Posted by: Lo2k
Same for me, Alchemy also works with my old Audigy Gamer and I can now select 2D and 3D hardware acceleration in game. Thanks for the tip.

Hi Guys :)

I have just installed Alchemy and my Audigy card trying to get the sound to work properly in Win 7 Ultimate x64, and when I add the GP4 folder in Alchemy, and then run the game... it just crashes...?! But without Alchemy the game runs fine, it just won't let me change the sound settings..??

Anybody know what I might be doing wrong? :(

Works fine without Alchemy but no 2d/3d sound, and crashes when I use Alchemy? Weird!



Edited 1 time(s). Last edit at 05/22/2010 09:00PM by TeamBPR.
IMO this thread should be pinned to the GP4 FAQ.



Order a giffgaff SIM from my link and get £5 credit, free!
Season 1 and Season 3 GPGSL World Champion!
Member of CTDP - Cars Tracks Development Program - 3D Carshaper
I also have problems with no hardware acceleration etc but I have realtek audio drivers instead of creative :/
vesuvius, try realtek soundback beta or alchemy universal and you should have hardware sound.

Thanks matt, it works perfectly now:)
wow, that cool, i'll try. I got a Realtek and i wanna try to improove GP4 performance :)

My workthread with all RELEASED and WIP stuff


ive been using win7 for 6 months now perfectly, since i came back to gp4 a few weeks ago im having the same problem, ive installed alchemy and its added files into my installation root but gp4's po is out the roof compared to xp,even though the 2d &3d options are now available gp4 keeps asking me to recalibrate sounds every time i load up and tbh it makes no difference in performance, i too have an audigy2 zs card,any help would be appreciated, cheers

RaceSimsPitstop

Game Screens
Thanx for the Alchemy tip, sovled the sound shuttering issue I have since switching to Win7 lately.

ccc
___________________________________________________________________________
For a list of EVERY download for GP4, look here:[docs.google.com]
Sorry, only registered users may post in this forum.

Click here to login

Maintainer: mortal, stephan | Design: stephan, Lo2k | Moderatoren: mortal, Vader, stephan | Downloads: Lo2k | Supported by: Atlassian Experts Berlin | Forum Rules | Policy