Problem with Hotseat AI and team dependant performance

Posted by DrTzTz 
Problem with Hotseat AI and team dependant performance
Date: September 02, 2020 11:56PM
Posted by: DrTzTz
Hello there.

I have the following problem: I wanted to use custom setting for driver performance, so I edited the performance files. So far no problem. Everything seemed to work just fine. I could definitely feel the differences and player and computer cars behaved accordingly.

Now for the problem: I wanted to use these settings in hotseat. The problem is, the Computer-controlled player driver is driving way too fast. I already searched the forum for solutions and for another user the upgrade to the latest GpXPatch seemed to have fixed the issue. Not for me sadly (always been on v4.52). I tried different things already. It seems the computer controlled player driver is driving on ace level, while we are driving on beginner for now. If I let them drive on ace their times seem to reflect the settings I gave them (~15k grip) very well. I tried to change the values in the magic data for the tracks, setting the values for the ace drivers lower, which absolutely workend on ace level for the normal computer drivers, but my computer controlled player driver just kept racing at his speed. At this point I really am at a loss for what to do next.

Now the question: Is there a way to have computer controlled player drivers in hotseat mode drive to the appropriate skill level for the difficulty setting you are using?

Help would be very much appreciated :(
Re: Problem with Hotseat AI and team dependant performance
Date: September 03, 2020 08:51AM
Posted by: npnc
I had encountered the problem and had also solved it ... I will try to check my settings when I can in GpXPatch and let you know.
This was the argument: [www.grandprixgames.org]
Bye



Edited 2 time(s). Last edit at 09/03/2020 08:52AM by npnc.
Re: Problem with Hotseat AI and team dependant performance
Date: September 06, 2020 08:26PM
Posted by: DrTzTz
Thanks for the comment, but that was the thread I was referencing earlier. I have the up to date version of GPxPatcher.

I tried out different things:

- my difficulty setting doesn't seem to affect the player-AI (I will just shortcut this to pc as player car and will mean the ai car when I say that). Lap-Times are around 1:20 on interlagos if I start GP without team dependant performance
- Settings in the performance file definitely affect the pc driver, I got times around 1:15 with 16499 grip and 770 BHP, around 1:21 with 16133 grip and 843 bhp
- Settings in the magic file don't seem to affect the pc driver, at least when I set everything to the beginner values on interlagos the cc drivers went the same speed on ace as on beginner, but my pc driver still went around 1:15 to 1:16, or maybe I didn't find the right setting
- The Performance of the pc driver seems to be better with team dependant performance enabled than without, although I have worse values on the team dependant performance than the standard for the player cars is.
- Player master grip doesn't seem to affect the pc driver at all, while it does definitely affect my grip when I drive myself. This might be a possible fix, but I also want to have different values for both players being active, so not ideal here...
- I was under the impression, that the pc driver seems to adjust to my times that i have driven in the races I had so far. I was about 3 sec faster on rookie than the cc drivers, and my pc driver seemed to adjust to around that level. I couldn't reproduce this in testing however. The pc driver stayed at his lap times even if I did up to five faster ones. More testing would be needed, but it's difficult to do.

In conclusion the question is: How does the pc driver even work? What influences it's speed? And how does this relate to team dependant performance settings?

Hopefully someone can shed some light on this? I will keep investigating...
Re: Problem with Hotseat AI and team dependant performance
Date: September 07, 2020 04:07AM
Posted by: TomMK
What setting have you selected for "Player car performance team dependent"?

It should be "power and grip" and not "Old behaviour". Just checking that's not the cause of the issue...



=====================================================


Intel NUC 8i3, 8GB RAM, MS Sidewinder Wheel
Re: Problem with Hotseat AI and team dependant performance
Date: September 07, 2020 06:46AM
Posted by: DrTzTz
I tried all of them to no avail, but have been using "Power and grip". So no, that doesn't seem to be the cause. But thanks.

I can add one further observation thanks to your image now though:
- the pc driver is still driving 1:16 - 1:17 times even when not using performance file but only checking team dependant performance. I was using a minardi and that is still too fast for them. And still same speed on rookie as on ace.
- the pc driver's speed is still dependent on the car he uses even when not using a custom performance file, as would be expected. So the default values in the game suffer from the same problem.

So it really seems the player AI driver just seems to behave strangely as is, even without any mods or patching. BUT there seems to be a seperate setting for the player AI driver's grip. He does get influenced by the performance values in the performance file. I would maybe guess there's something like a "player master grip" for the player AI driver as well? Just not a setting I can find anywhere. PC driver is driving faster with team dependant performance enabled than without it. That I don't get at all. If at all they should be driving slower, because the player values would be better than the team dependant performance values.... I don't know. Still hoping there can be a solution.
So I worked around this problem by increasing the player master grip and reducing the Performance values of the player cars accordingly. Reducing grip by around 1000 and then increasing player master grip by around 2000 seems to be a good fix so far for beginner level. Still I wanna ask again: Does anybody know what causes this problem, and if there can be a real fix for it?
Re: Problem with Hotseat AI and team dependant performance
Date: October 16, 2020 08:35AM
Posted by: npnc
I seem to remember that if you use the default setup for your cars you should solve the problem
Let me know.
Hello
Sorry, only registered users may post in this forum.

Click here to login

Maintainer: mortal, stephan | Design: stephan, Lo2k | Moderatoren: mortal, Vader, stephan | Downloads: Lo2k | Supported by: Atlassian Experts Berlin | Forum Rules | Policy