Team Editor Erreur E/S 998

Posted by kedy89 
Team Editor Erreur E/S 998
Date: August 07, 2018 01:59PM
Posted by: kedy89
Been trying to get the tweaker coordinates for the 2018 cars. After inserting the carshapes into the wad, I get this error message when trying to switch to quickcam 1. Happened with the Ferrari and Mercedes, yet to try the other cars.
[i.imgur.com]



Some mods
::: F1 1996 ::: F1 2002 ::: F1 2007 ::: F1 2011 ::: F1 2013 ::: F1 2015 ::: F1 2018 :::

Some other stuff ::: Some more other stuff
Re: Team Editor Erreur E/S 998
Date: August 07, 2018 04:19PM
Posted by: vesuvius
Happends to me as well. Carshapes are so heavy.
Re: Team Editor Erreur E/S 998
Date: August 07, 2018 05:57PM
Posted by: kedy89
Managed to grab most of them now by continuously trying, error seems to pop up at random, not a specific car.



Some mods
::: F1 1996 ::: F1 2002 ::: F1 2007 ::: F1 2011 ::: F1 2013 ::: F1 2015 ::: F1 2018 :::

Some other stuff ::: Some more other stuff
Re: Team Editor Erreur E/S 998
Date: August 07, 2018 07:34PM
Posted by: Excalibur
Error E/S 998 means Invalid access to memory location

I have got a runtime error 216 at 00403E72 randomly but always when I change the team from the carshape tab in V or Tcam view , probably due to the weight of the lods_0 which are loaded by TeamEditor. It is right to say that the cars are heavy...but always into the GP4 limits in terms of Vertices/ Faces (65535). I hope that the cars will be a bit lighter with the 2019 rules and less aero parts.

I tried some things without success:
1- using the 4Gb patch for X86 programs or to modify the .exe or with CFF Explorer to allocate more virtual memory for the program : when using this, I have got the error E/S 998
2- using the cleanTEkey.bat: It works fine for a moment but the runtime error comes back quickly

Before to display the Runtime error message, I have got this message:


Strange that I had this problem more often recently. I didn't change my cars.wad and always under Windows 7 (x64) . Just a new updates for my CG and windows security updates. That's all.

I am trying over things to fix this problem. But I am quite sure that E/S 998 and runtime error 216 at 00403E72 have the same cause.

____________________________________________________________________________________________________________________________________________

Re: Team Editor Erreur E/S 998
Date: August 07, 2018 10:51PM
Posted by: bencoull
Pareil Excalibur, j'ai ce problème là depuis 2-3 jours quand je veux régler la t-cam et les positions du casque et volant.
Re: Team Editor Erreur E/S 998
Date: August 07, 2018 10:55PM
Posted by: Excalibur
@bencoull: Interesting that you have the same problem since a few days, too... Did you modify something into your cars.wad recently?

____________________________________________________________________________________________________________________________________________

Re: Team Editor Erreur E/S 998
Date: August 10, 2018 01:38PM
Posted by: bencoull
Did you find the origin of the problem Excalibur ?
Re: Team Editor Erreur E/S 998
Date: August 10, 2018 03:20PM
Posted by: Excalibur
Yes. I tried with the original gp4 cars.wad and I have got no E/S or runtime error anymore.
So, I guess that the problem occurs with heavy lods.

The solution may be to make a cars.wad with lower lods (only lod_1 or lod_2, for example) just for TeamEditor.
1- Make a backup of your cars.wad
1- Delete lods_0, lods_1, lods_3, lods and lods_4 from your cars.wad, excepted lods_2
2- Rename lods_2 as lods_0
3- Recompile your wad
4- Open TeamEditor and go into the options tab/ change cars wad path to select the wad modified
5- Set your cameras and others positions as you wish but Don't click on the apply button!
5bis- Don't forget that for the tyres positions, you have to note tyres positions for each team, then to report them into GP4Tweaker (gp4tweak_data/ tyrepos.ini from your main GP4 folder)
6- Just save Team file (File/ save team file)
7- Change cars wad path to your original cars.wad from your main Grand Prix 4 folder
8- File/ load team file. Then, cameras and others positions should be applied to your cars.wad
9- click on the apply button

Edit: This doesn't work. Maybe a problem with one or several cars that TeamEditor can't manage to load correctly

The other way is to use RT Edit in game to set Cams/ helmets/ tyres/ St wheel positions: [www.grandprixgames.org]

____________________________________________________________________________________________________________________________________________





Edited 1 time(s). Last edit at 08/10/2018 06:01PM by Excalibur.
Sorry, only registered users may post in this forum.

Click here to login

Maintainer: mortal, stephan | Design: stephan, Lo2k | Moderatoren: mortal, Vader, stephan | Downloads: Lo2k | Supported by: Atlassian Experts Berlin | Forum Rules | Policy