Grand Prix 3 + Win10 + Logitech Rumblepad F510 problem. <<SOLVED>>

Posted by abdelkader 
Hey everyone.

It's my first topic on this forum in years!!!
I quit playing our beloved game and reinstalled it only this week to relive the joy I used to have.

I've installed VMWare player, installed Windows XP on it and installed GP3. The game started but it was noticeable that it's working waaaay too slow. The sound was too slow and so was the FPS. I effortlessly calibrated the Rumblepad but because of the lag, it wasn't possible to play the game. When I tried to run the game again, some hours later, to my surprise this time the game wouldn't start and hasn't started ever since. The screen turns black and nothing happens. Which is strange because I used GP3+VMWare Player+Windows XP combo already some years ago and it worked perfectly fine. The only difference being that I used to use Windows 7 as a host system and now, of course, it's Windows 10.

Anyway, not discouraged by this, I decided to run GP3 directly on Windows 10. The game started effortlessly (despite a psychedelic main menu). However, when trying to calibrate my Logitech Rumblepad F510, I noticed that GP3 wouldn't allow it as it simply doesn't "see" my joypad. Which is also strange because all the other games I use recognize it perfectly fine, plus, I even used the very same joypad when playing GP3 via VMWare Player+Windows XP some years ago (when I used Windows 7 instead of Windows 10). I honestly don't know why the game suddenly doesn't recognize my joypad anymore.

So, I have 2 questions at the moment. If I get a good answer to one of them, the other one doesn't need any answer anymore.

1)How do I make GP3 work (again) on VMWare Player/Windows XP system? Is the new version of VMWare player sort of different to the old version? Is Windows 10 causing the black screen on my VMWare Player/Windows XP? What is causing the lag?

2)How do I force GP3 to recognize and calibrate my Logitech Rumblepad F510, when run directly on Windows 10?

Thank you in advance!



<<EDIT>>

Last night I gave up, switched my PC off and went to bed. This morning, I turned the PC on, run GP3 and went to the calibration screen...and it worked immediately. I think that my PC simply needed a reset after the installation which helped GP3 recognize the joypad. So happy







Edited 3 time(s). Last edit at 02/10/2019 11:58AM by abdelkader.
But WM-player was not useful for running GP2 on windows XP?

For GP3 it is not necessary!

Try my work, without VM-Player:

[www.grandprixgames.org]
Thank you !



Sorry, only registered users may post in this forum.

Click here to login

Maintainer: mortal, stephan | Design: stephan, Lo2k | Moderatoren: mortal, Vader, stephan | Downloads: Lo2k | Supported by: Atlassian Experts Berlin | Forum Rules | Policy